별거 아닌 팁이고 사용하실 분도 거의 안 계시겠지만 혹시라도 저와 비슷한 문제를 겪고 계신 분들이 있을까봐 소개해드립니다.

예전엔 안 그랬던 것 같은데 요즘은 KMP로 동영상을 시청하면 항상 15분 뒤에 문제가 발생합니다. 15분이 지나면 화면이 잠시 깜빡인 다음 에어로가 꺼지는데 (그러니까 15분동안 마우스 키보드 안 건드리고 동영상만 시청하는 경우) 그때부터 약 30초 정도 화면이 버벅이고 깨집니다. 그러다 다시 한번 화면이 깜빡이고 나서는 정상적으로 재생됩니다. 그냥 동영상 볼 때는 그나마 참을 수 있는데 TP 파일 녹화중에는 스트림 에러가 발생할 수 있어서 신경이 날카로워 지더군요.

일단 직접적인 해결책은 찾지 못했습니다. 동일 증상을 호소하시는 분들을 몇몇 보긴 했지만 저를 포함한 극소수의 문제일 것이라 생각하고 그냥 넘어갔습니다. 15분 뒤에 에어로가 꺼지지 않도록 해보려고 전원 옵션을 다 뒤지고 이리저리 설정해봤지만 문제는 해결되지 않았습니다.

그러던 어느날 문득 생각해낸 방법이 바로 이것입니다. 애초에 KMP를 시청할 때 에어로를 끄고 시청하는 것. 그러면 중간에 에어로가 꺼질 일이 없으니 동영상 재생시 문제가 발생하지 않을 것이라는 추론. 결과는 성공이었습니다. 에어로를 끄고 KMP를 시청하니 아무런 문제가 발생하지 않았습니다.

그런데 매번 KMP를 시청할 때 마다 에어로를 수동으로 끌 수는 없는 노릇이니... (귀찮으니까요)

이 글의 제목처럼 특정 프로그램에서만 에어로를 끄도록 설정할 수 있습니다. 예전에 스타크래프트 화면 깨짐 현상 때문에 이리저리 만져보셨던 분들이라면 아마 기억하실 것입니다. 그것은 바로...



KMP 아이콘에 우클릭 해서 속성으로 들어가 위 그림처럼 설정하시면 됩니다. 그러면 KMP 실행시 자동으로 에어로가 꺼지고 KMP를 끄면 다시 에어로가 켜집니다.

문제 상황에 직면했을 때 직접적인 문제의 원인을 해결하려 집착하기 보다는 다른 각도로 발상의 전환을 해보는 것도 필요한 것 같습니다.
신고

Tag : , ,
  1. 카리스마조
    2010.05.26 09:21 신고

    오늘도 1등입니다. ^^

  2. BlogIcon 공피
    2010.05.26 09:27 신고

    다음팟플 개발자 버전 쓰고 있는데 Aero 기능 쓰고 있지만 그런 문제는 없네요 ^^;;
    여튼 유용한 팁 감사합니다 ㅎㅎ;;

  3. Bisu
    2010.05.26 11:18 신고

    텍큐 쓰다가 티스토리로 넘어왔는데
    글분류 어떻게 추가해요 스눕형 ㅠㅠ

  4. 거북이학자
    2010.05.26 11:52 신고

    씁쓸합니다. 요즘 미디어 플레이어 대세는 팟플과 톡플인가봐요.
    KMP 계속 쓰고 있는데 바꿔볼까 생각중이에요

  5. 매력파니
    2010.05.26 16:41 신고

    저두 KMP 쓰다가 동일한 증상을 겪어서 검색을 좀 해보니
    KMP 화면에서 고급영상처리 설정이 에어로기능과 충돌한다더군요.
    그래서 KMP 기본설정이 고급영상처리-비디오렌더러 장치-오버레이믹서로
    되어있는데 이걸 Enhanced Video Renderer 로 바꿔주니 증상이 싹 사라졌습니다.

    • BlogIcon snpbox
      2010.05.27 08:45 신고
      수정 및 삭제

      네 대충 보니 VMR9 Renderless가 에어로가 꺼질 때 문제를 일으키는 것 같습니다.

  6. 흑기사
    2010.05.26 17:42 신고

    죄송하지만.... 윈도우7 얼티밋 영문판 쓰시고계신분중에...
    레지스트리에서 mui 폴더내에 en-us 레지스트리파일좀 보내주실수있으신분..
    다름이 아니라.. 전 울티메이트 k 인지라...
    순정 영문울티메이트를 못구해서... 울티메이트 k 에서 레지 mui 에있는 ko-kr 을 삭제하니까
    울티메이트로 변경은 되었는데... 문제는 업데이트가안되드라구요.. 그래서 미리복사해논 ko-kr 레지파일을 다시 실행해서 붙여넣으니까 업뎃을되는데.. 문제는 주언어를 영어로 인식하고 한글언어팩은 다운로드및 설치가 안되드라구요.. 왜냐면... ko-kr 레지를 입력해줬기때문인듯.. 그래서... 결론은 제 윈도우7 울티밋k 에있는 mui 레지에서 en-us 와 ko-kr 을 다지우고..
    영문윈도우7 얼티밋 레지에 mui > en-us 레지 파일을 붙여넣고 재부팅후 한글언어팩을 깔면 되겠구나 하는..
    그래서 그러니.. 영문윈도우7 쓰시는분 레지에서 mui - en-US 좀 보내주세요... ㅠㅠ
    stayopen@naver.com 부탁드려요..

  7. 나누밍
    2010.05.26 18:39 신고

    저도 다음팟 쓰면서 간간히 그런 현상이 있어서 MPC로 쓰고 있는데.. 그런 이유인가 보네요

  8. 죄송하지만 질문좀 ...
    2010.05.26 19:09 신고

    자막이 나올때도 있고 안나올때도 있는데
    그건 왜그런지 아시나요
    저도 KMP쓰는데 자막이 안나오는 것들은 맨 처음에 살짝 보이다가 빠르게 사라지는데 증상은 아래 링크입니다.혹시 해결방법 아세요 ..?
    http://kin.naver.com/qna/detail.nhn?d1id=1&dirId=1020401&docId=109637257
    이거인데 .. 자막이 인식은 분명 되는데 ㅜㅜ

  9. BlogIcon Anam
    2010.05.26 20:14 신고

    흠..저도 윈7을 사용하고 있고 , 동영상 플레이어는 주로 쓰는게 Kmp인데 본문에 나온 증상은 처음 듣네요 ㄷㄷ.. 스트레스 쌓이겠다는-_-;;;;

  10. 응삼이
    2010.05.26 20:22 신고

    저도 아직은 저런증상은 안보이네요 ;; 다음 팟플이랑 KMP번갈아 쓰는뎅 ;; ;;

  11. BlogIcon Hong_1998
    2010.05.26 20:53 신고

    저기 스누피님, 질문이 있는데요 예전에 소개시켜주신 테스트드라이브요,
    포맷하다가 잘못해서 백업파티션을 날려벼렸는데.. 거기에다 다시 파티션을 만들고 자료를 하나씩 쌓고있습니다.
    그런데 테스트드라이브로 복구할 수 있을까요? 바탕화면이나 유틸은 다시 구하면 되지만 사진들을 통으로 옮겨놓은지라..ㅠㅠㅠㅠㅠㅠㅠ

    • BlogIcon snpbox
      2010.05.27 08:57 신고
      수정 및 삭제

      글쎄요.. 한번 해봐야 알겠지요. 날려버린 상태에서 다시 만든건 상관이 없을텐데 자료를 쌓고있다 하시니 복구 가능성은 점점 줄어들고 있을 것 같습니다.

  12. BlogIcon 꿈의 별
    2010.05.26 21:45 신고

    저는 윈도우7의 윈미플12가 멋있고 편하네요~ ^^

  13. BlogIcon tadLee
    2010.05.26 22:22 신고

    새로운걸 알았네요.
    기억하고 있다가 나중에 문제 생기면 확인해 봐야 겟습니댜.


  14. 2010.05.26 23:19

    비밀댓글입니다

    • BlogIcon snpbox
      2010.05.27 08:59 신고
      수정 및 삭제

      웬만하면 그냥 인증될텐데요? 비어있는 하드에 설치하셨나요? 만약 지금 안된다면 그상태로 다시 윈도우 설치하시면 됩니다. 단 포맷은 반드시 윈도우 설치화면의 파티션 선택 부분에서 해줘야 합니다.

  15. a
    2010.05.26 23:48 신고

    저도 저런증상이 있었는데 위에 댓글달으신 매력파니님과 같은방법으로 해결한기억이 나네요. 팟플로 바꾸고선 그런문제가 없었구요

  16. BlogIcon 빈손이
    2010.05.29 20:35 신고

    저는 잘 작동하더군요...
    기본값에 코댁만 별도로 심고 렌더러도 기본값이고... 뭐가 문제일까요?

  17. BlogIcon 축복
    2010.05.30 10:15 신고

    퍼갑니다 ^ㅡ^

  18. 아쿠아 플레이어
    2010.09.04 18:39 신고

    음 .. 아쿠아플레이어를 이렇게 설정시 재생시엔 에어로기능이 꺼지지만
    아쿠아 플레이어를 종료 후에 복원이 안되는군요 ㅠㅠ
    딴 방법을 강구해봐야겠어요 ㅠ